Back to overview
Maintenance

Metaplay Managed Platform Infrastructure Update

Aug 29 at 12:00pm EEST  –  Aug 29 at 01:57pm EEST
Affected services
p1.metaplay.io
p2-eu.metaplay.dev

Resolved
Aug 29 at 01:57pm EEST

Maintenance work has successfully finished.

Updated
Aug 29 at 01:29pm EEST

All production servers on p1.metaplay.io stack have been updated successfully.

Created
Aug 29 at 12:00pm EEST

We are planning to do an infrastructure update in our managed platform (p1.metaplay.io/p2-eu.metaplay.dev) on Friday, Aug 29th, 2025, starting at 12:00 (Finnish time) and are expecting the maintenance to take at most two hours and end by 14:00 (Finnish time).